Engine is out

July 13, Fri
Affected Service: Engine
  • Identified
    Following the incident earlier today, our engine needs to be brought down again for maintenance. We apologize for the inconvenience.

    19:28, Jul 12 UTC
  • Resolved
    The engine is now back and running.

    06:19, Jul 13 UTC
Back to current status